ath9k: disable PA predistortion by default, since it has been reported to reduce...
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index 2391e098c684bee20a0da00ec23f86b4defebb21..c7d59f12029152fa2887e2374949c378ef918de7 100644 (file)
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 PKG_NAME:=Build dependency
 
@@ -70,6 +71,27 @@ $(eval $(call Require,working-g++, \
        Please install the GNU C++ Compiler (g++). \
 ))
 
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/working-gcc-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -
+  endef
+
+  $(eval $(call Require,working-gcc-static, \
+    Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
+  ))
+
+  define Require/working-g++-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(TMP_DIR)/a.out
+  endef
+
+  $(eval $(call Require,working-g++-static, \
+       Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL). \
+  ))
+endif
+
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses
@@ -89,14 +111,21 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/zlib-static
+       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
+               gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz
+  endef
+
+  $(eval $(call Require,zlib-static, \
+       Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL). \
+  ))
+endif
+
 $(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))
 
-$(eval $(call RequireCommand,flex, \
-       Please install flex. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))