ath9k: disable PA predistortion by default, since it has been reported to reduce...
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index afb92ff02160473598cfb737a04567e7c9c0b327..c7d59f12029152fa2887e2374949c378ef918de7 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 PKG_NAME:=Build dependency
 
@@ -18,16 +19,9 @@ $(eval $(call Require,non-root, \
        Please do not compile as root. \
 ))
 
-define Require/umask-0022
-       [ "$$(shell umask)" -eq 22 ]
-endef
-$(eval $(call Require,umask-0022, \
-       Please compile with umask 0022. \
-))
-
 # Required for the toolchain
 define Require/working-make
-       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 == "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -77,6 +71,27 @@ $(eval $(call Require,working-g++, \
        Please install the GNU C++ Compiler (g++). \
 ))
 
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/working-gcc-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -
+  endef
+
+  $(eval $(call Require,working-gcc-static, \
+    Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
+  ))
+
+  define Require/working-g++-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(TMP_DIR)/a.out
+  endef
+
+  $(eval $(call Require,working-g++-static, \
+       Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL). \
+  ))
+endif
+
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses
@@ -96,14 +111,21 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/zlib-static
+       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
+               gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz
+  endef
+
+  $(eval $(call Require,zlib-static, \
+       Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL). \
+  ))
+endif
+
 $(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))
 
-$(eval $(call RequireCommand,flex, \
-       Please install flex. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -128,6 +150,14 @@ $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
 
+define Require/git
+       git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call Require,git, \
+       Please install git (git-core) v1.6.5 or later. \
+))
+
 define Require/gnutar
        $(TAR) --version 2>&1 | grep GNU > /dev/null
 endef