revert find | xargs => find | exec changes - this is completely unnecessary and intro...
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index ed8fdb6fceffd0c61d3a7a3f6c6b823ce4b6ecce..d3aec643999c81501b5adc8f73d7189097dfc6ac 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 
+PKG_NAME:=Build dependency
+
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
@@ -76,6 +78,9 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+$(eval $(call RequireCommand,gawk, \
+       Please install GNU awk. \
+))
 
 $(eval $(call RequireCommand,bison, \
        Please install GNU bison. \
@@ -85,10 +90,6 @@ $(eval $(call RequireCommand,flex, \
        Please install flex. \
 ))
 
-$(eval $(call RequireCommand,python, \
-       Please install python. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -116,3 +117,7 @@ endef
 $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
+
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
+))