add prereq check for extended getopt (#3944)
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index c73b12438fff3916441aa22a76ba4216f6aa2ebd..d6d2d73a63c39549936e19f5e2e4c2920f2fbd55 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 
+PKG_NAME:=Build dependency
+
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
@@ -18,11 +20,7 @@ $(eval $(call Require,non-root, \
 
 # Required for the toolchain
 define Require/working-make
 
 # Required for the toolchain
 define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
 endef
 
 $(eval $(call Require,working-make, \
@@ -50,7 +48,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
 endef
 
 $(eval $(call Require,working-g++, \
@@ -76,6 +75,9 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+$(eval $(call RequireCommand,gawk, \
+       Please install GNU awk. \
+))
 
 $(eval $(call RequireCommand,bison, \
        Please install GNU bison. \
 
 $(eval $(call RequireCommand,bison, \
        Please install GNU bison. \
@@ -101,6 +103,10 @@ $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
 
        Please install perl. \
 ))
 
+$(eval $(call RequireCommand,python, \
+       Please install python. \
+))
+
 $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
 $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
@@ -113,8 +119,26 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
        Please install GNU tar. \
 ))
 
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
+define Require/gnu-find
+       $(FIND) $(TMP_DIR) -lname foo
+endef
+
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
+))
 
 
+define Require/getopt-extended
+       getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+       Please install an extended getopt version that supports --long \
+))