improve support for building on mac os x by improving detection of missing components
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index 11ee111ced333dcc6286e9df3089c66a9ad8cb96..f0e1da9810d2f51c934cb63e364195e77ae69f2c 100644 (file)
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
+define Require/getopt
+       getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+       Please install GNU getopt \
+))
+
+define Require/fileutils
+       gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+       Please install GNU fileutils \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
@@ -103,6 +117,10 @@ $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
 
+$(eval $(call RequireCommand,python, \
+       Please install python. \
+))
+
 $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
@@ -123,3 +141,18 @@ $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
+define Require/gnu-find
+       $(FIND) $(TMP_DIR) -lname foo
+endef
+
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
+))
+
+define Require/getopt-extended
+       getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+       Please install an extended getopt version that supports --long \
+))