add prereq check for python
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index d3aec643999c81501b5adc8f73d7189097dfc6ac..fbe7d69f4483f1bcffe636c3adeb999e33cbec8d 100644 (file)
@@ -20,11 +20,7 @@ $(eval $(call Require,non-root, \
 
 # Required for the toolchain
 define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -52,7 +48,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -106,6 +103,10 @@ $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
 
+$(eval $(call RequireCommand,python, \
+       Please install python. \
+))
+
 $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
@@ -118,6 +119,18 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
+
+define Require/gnu-find
+       $(FIND) $(TMP_DIR) -lname foo
+endef
+
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
+))