Fix the error on the quota extension (#2080)
[openwrt/svn-archive/archive.git] / include / prereq.mk
index 8a08be8e68c9f4d34b0b8085c99ab01602bd21f5..8e5490ccff80161233cc76bede40f16f0e22d696 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -47,3 +47,12 @@ define RequireCommand
   $$(eval $$(call Require,$(1),$(2)))
 endef
 
+define RequireHeader
+  define Require/$(1)
+    [ -e "$(1)" ]
+  endef
+  
+  $$(eval $$(call Require,$(1),$(2)))
+endef
+
+.NOTPARALLEL: