generate md5 checksums of generated firware images. closes #4003
[openwrt/svn-archive/archive.git] / include / quilt.mk
index 04ebfc3490c9bf7e04621efaaebc4532d8ca1e44..07bab8b440c3e8090ab9a811aeb4dd24a48df38d 100644 (file)
@@ -12,6 +12,7 @@ ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
 PATCH_DIR?=./patches
+FILES_DIR?=./files
 
 ifeq ($(MAKECMDGOALS),refresh)
   override QUILT=1
@@ -56,7 +57,6 @@ ifneq ($(QUILT),)
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
   STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
   override CONFIG_AUTOREBUILD=
-  $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   prepare: $(STAMP_PATCHED)
   quilt-check: $(STAMP_CHECKED)
 endif
@@ -67,9 +67,12 @@ define Build/Patch/Default
 endef
 
 define Kernel/Patch/Default
-       $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
-       if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+       rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
+       if [ -d $(GENERIC_FILES_DIR) ]; then $(CP) $(GENERIC_FILES_DIR)/* $(LINUX_DIR)/; fi
+       if [ -d $(FILES_DIR) ]; then \
+               $(CP) $(FILES_DIR)/* $(LINUX_DIR)/; \
+               find $(LINUX_DIR)/ -name \*.rej | xargs rm -f; \
+       fi
        $(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
        $(call PatchDir,$(PATCH_DIR),platform/)
 endef
@@ -101,32 +104,33 @@ define Quilt/Refresh
 $(if $(TARGET_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 endef
 
-$(STAMP_PATCHED): $(STAMP_PREPARED)
+define Build/Quilt
+  $(STAMP_PATCHED): $(STAMP_PREPARED)
        @( \
                cd $(PKG_BUILD_DIR)/patches; \
                quilt pop -a -f >/dev/null 2>/dev/null; \
                if [ -s ".subdirs" ]; then \
                        rm -f series; \
-                       for file in $$(cat .subdirs); do \
-                               if [ -f $$file/series ]; then \
+                       for file in $$$$(cat .subdirs); do \
+                               if [ -f $$$$file/series ]; then \
                                        echo "Converting $$file/series"; \
-                                       $(call filter_series,$$file/series) | awk -v file="$$file/" '$$0 !~ /^#/ { print file $$0 }' | sed -e s,//,/,g >> series; \
+                                       $$(call filter_series,$$$$file/series) | awk -v file="$$$$file/" '$$$$0 !~ /^#/ { print file $$$$0 }' | sed -e s,//,/,g >> series; \
                                else \
-                                       echo "Sorting patches in $$file"; \
-                                       find $$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
+                                       echo "Sorting patches in $$$$file"; \
+                                       find $$$$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
                                fi; \
                        done; \
                else \
                        find * -type f \! -name series | sort > series; \
                fi; \
        )
-       touch $@
+       touch $$@
 
-$(STAMP_CHECKED): $(STAMP_PATCHED)
+  $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
+  $(STAMP_CHECKED): $(STAMP_PATCHED)
        if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
-       touch $@
+       touch $$@
 
-define Build/Quilt
   quilt-check: $(STAMP_PREPARED) FORCE
        @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
@@ -144,7 +148,7 @@ define Build/Quilt
   refresh: quilt-check
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
        @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
-               quilt refresh; \
+               quilt refresh -p ab --no-index --quiltrc=/dev/null --no-timestamps; \
        done; ! quilt next 2>/dev/null >/dev/null
        $(Quilt/Refresh)