some minor fixes, cleanups, package build abstraction
[openwrt/svn-archive/archive.git] / include / quilt.mk
index a2cbdf9eeb49a5a472d43508eb53ce91f53b631f..4dce2a6d8ca2ef59312ab255d8c3100b1a2ce941 100644 (file)
@@ -5,6 +5,9 @@
 # See /LICENSE for more information.
 #
 
+ifneq ($(__quilt_inc),1)
+__quilt_inc:=1
+
 ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
@@ -26,7 +29,6 @@ endef
 
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
-  STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
   override CONFIG_AUTOREBUILD=
   define Build/Patch/Default
@@ -135,3 +137,4 @@ refresh: quilt-check
 update: quilt-check
        $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 
+endif