fail in .quilt_patched when there were patches that didn't apply
[openwrt/svn-archive/archive.git] / include / quilt.mk
index fb5528e884c6762a8fdc71a01232788f2cda77e7..7714f2911919a843e75db4dc1fc6c7808955e003 100644 (file)
@@ -61,7 +61,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
                cd $(PKG_BUILD_DIR)/patches; \
                find * -type f \! -name series | sort > series; \
        )
-       -[ -s "$(PKG_BUILD_DIR)/patches/series" ] && (cd $(PKG_BUILD_DIR); quilt push -a)
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@
 
 define Quilt/RefreshDir