ep93xx: switch to 3.3 and add broken flag
[openwrt/svn-archive/archive.git] / include / quilt.mk
index 9309fc94b76f27719d239d07f7187b7daa84b4f9..925b7a736bd83710331c4396b804d8593505e58f 100644 (file)
@@ -39,7 +39,8 @@ define PatchDir/Quilt
 endef
 
 define PatchDir/Default
-       @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+       @if [ -d "$(2)" ] && [ "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+               export PATCH="$(PATCH)"; \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
                                $(KPATCH) "$(1)" "$(2)"; \
@@ -124,7 +125,8 @@ define Quilt/Refresh/Kernel
 endef
 
 define Quilt/Template
-  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED) FORCE
+  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED)
+  $(if $(NO_RECONFIGURE),$($(2)STAMP_BUILT),$($(2)STAMP_CONFIGURED)): FORCE
   $($(2)STAMP_CHECKED): $($(2)STAMP_PREPARED)
        if [ -s "$(1)/patches/series" ]; then \
                (cd "$(1)"; \