fix spontaneous rebuilds caused by make package/<name>/update with quilt
[openwrt/svn-archive/archive.git] / include / quilt.mk
index dc5a9d2b698e002b0a26020bd669f300c2d3a4b2..a7aac91c06cd230975655ef0869e258c46415d0d 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 
-ifeq ($(KERNEL_BUILD),1)
+ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
 PATCH_DIR?=./patches
@@ -15,7 +15,7 @@ ifeq ($(MAKECMDGOALS),refresh)
 endif
 
 define Quilt/Patch
-       @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
+       @for patch in $$$$( (cd $(1) && if [ -f series ]; then grep -v '^#' series; else ls; fi; ) 2>/dev/null ); do ( \
                cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
                cd $(PKG_BUILD_DIR); \
                quilt import -P$(2)$$$$patch -p 1 "$$$$patch"; \
@@ -26,7 +26,6 @@ endef
 
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
-  STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
   override CONFIG_AUTOREBUILD=
   define Build/Patch/Default
@@ -59,6 +58,25 @@ define Kernel/Patch/Default
        $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
+ifeq ($(TARGET_BUILD),1)
+$(STAMP_PATCHED): $(STAMP_PREPARED)
+       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+       (\
+               cd $(PKG_BUILD_DIR)/patches; \
+               rm -f series; \
+               for file in *; do \
+                       if [ -f $$file/series ]; then \
+                               echo "Converting $$file/series"; \
+                               awk -v file="$$file/" '$$0 !~ /^#/ { print file $$0 }' $$file/series >> series; \
+                       else \
+                               echo "Sorting patches in $$file"; \
+                               find $$file/* -type f \! -name series | sort >> series; \
+                       fi; \
+               done; \
+       )
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
+       touch $@
+else
 $(STAMP_PATCHED): $(STAMP_PREPARED)
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
        (\
@@ -67,6 +85,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
        )
        if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@
+endif
 
 define Quilt/RefreshDir
        mkdir -p $(1)