[x86]
[openwrt/svn-archive/archive.git] / include / quilt.mk
index 9309fc94b76f27719d239d07f7187b7daa84b4f9..a9af2268bc2273b8b12665e3248a4fd59edba55b 100644 (file)
@@ -39,7 +39,8 @@ define PatchDir/Quilt
 endef
 
 define PatchDir/Default
-       @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+       @if [ -d "$(2)" ] && [ "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+               export PATCH="$(PATCH)"; \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
                                $(KPATCH) "$(1)" "$(2)"; \