merge quilt return code checks from trunk to 8.09
[openwrt/svn-archive/archive.git] / include / quilt.mk
index 70bc84e4cce6a56f4f6ca70becb30371ddc881a3..d7342c959f3eec5b85a3c1c9a4c171442bf20ef9 100644 (file)
@@ -128,7 +128,7 @@ define Build/Quilt
 
   $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   $(STAMP_CHECKED): $(STAMP_PATCHED)
-       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top >/dev/null 2>&1; fi); fi
        touch $$@
 
   quilt-check: $(STAMP_PREPARED) FORCE