add support for the user led on the avila
[openwrt/svn-archive/archive.git] / include / quilt.mk
index 6ae615792fe093c50f1f5290c48cb385ea2c3950..f07f4c5249524b94c0176dd75ed0c774f2562a47 100644 (file)
@@ -23,8 +23,8 @@ endef
 
 define PatchDir/Quilt
        @if [ -s $(1)/series ]; then \
-               mkdir -p $(PKG_BUILD_DIR)/patches$(if $(2),/$(2)); \
-               cp $(1)/series $(PKG_BUILD_DIR)/patches$(if $(2),/$(2))/; \
+               mkdir -p $(PKG_BUILD_DIR)/patches/$(2); \
+               cp $(1)/series $(PKG_BUILD_DIR)/patches/$(2); \
        fi
        @for patch in $$$$( (cd $(1) && if [ -f series ]; then $(call filter_series,series); else ls; fi; ) 2>/dev/null ); do ( \
                cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
@@ -54,10 +54,10 @@ endef
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
+  STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
   override CONFIG_AUTOREBUILD=
-  $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
   prepare: $(STAMP_PATCHED)
-  quilt-check: $(STAMP_PATCHED)
+  quilt-check: $(STAMP_CHECKED)
 endif
 
 define Build/Patch/Default
@@ -100,29 +100,33 @@ define Quilt/Refresh
 $(if $(TARGET_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 endef
 
-$(STAMP_PATCHED): $(STAMP_PREPARED)
+define Build/Quilt
+  $(STAMP_PATCHED): $(STAMP_PREPARED)
        @( \
                cd $(PKG_BUILD_DIR)/patches; \
                quilt pop -a -f >/dev/null 2>/dev/null; \
                if [ -s ".subdirs" ]; then \
                        rm -f series; \
-                       for file in $$(cat .subdirs); do \
-                               if [ -f $$file/series ]; then \
+                       for file in $$$$(cat .subdirs); do \
+                               if [ -f $$$$file/series ]; then \
                                        echo "Converting $$file/series"; \
-                                       $(call filter_series,$$file/series) | awk -v file="$$file/" '$$0 !~ /^#/ { print file $$0 }' >> series; \
+                                       $$(call filter_series,$$$$file/series) | awk -v file="$$$$file/" '$$$$0 !~ /^#/ { print file $$$$0 }' | sed -e s,//,/,g >> series; \
                                else \
-                                       echo "Sorting patches in $$file"; \
-                                       find $$file/* -type f \! -name series | sort >> series; \
+                                       echo "Sorting patches in $$$$file"; \
+                                       find $$$$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
                                fi; \
                        done; \
                else \
                        find * -type f \! -name series | sort > series; \
                fi; \
        )
-       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
-       touch $@
+       touch $$@
+
+  $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
+  $(STAMP_CHECKED): $(STAMP_PATCHED)
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
+       touch $$@
 
-define Build/Quilt
   quilt-check: $(STAMP_PREPARED) FORCE
        @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
@@ -132,7 +136,7 @@ define Build/Quilt
                echo "The source directory contains no quilt patches."; \
                false; \
        }
-       @[ -n "$$$$(ls $(PKG_BUILD_DIR)/patches/*/series)" -o "$$$$(cat $(PKG_BUILD_DIR)/patches/series | md5sum)" = "$$(sort $(PKG_BUILD_DIR)/patches/series | md5sum)" ] || { \
+       @[ -n "$$$$(ls $(PKG_BUILD_DIR)/patches/series)" -o "$$$$(cat $(PKG_BUILD_DIR)/patches/series | md5sum)" = "$$(sort $(PKG_BUILD_DIR)/patches/series | md5sum)" ] || { \
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }