improve support for building on mac os x by improving detection of missing components
[openwrt/svn-archive/archive.git] / include / scan.mk
index 28f526aa335ed94b5c18a21efb2640d98f2c030f..7b818e8aba3c2282c86eb4bda9b432cb39a14e04 100644 (file)
@@ -17,7 +17,7 @@ ifeq ($(IS_TTY),1)
   endef
 else
   define progress
-       :
+       :;
   endef
 endif
 
@@ -49,10 +49,10 @@ $(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
 
 -include $(TMP_DIR)/info/.files-$(SCAN_TARGET).mk
 
-$(TARGET_STAMP):
-       ( \
+$(TARGET_STAMP)::
+       +( \
                $(NO_TRACE_MAKE) $(FILELIST); \
-               MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) | awk '{print $$1}'); \
+               MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) 2>/dev/null | awk '{print $$1}'); \
                [ -f "$@.$$MD5SUM" ] || { \
                        rm -f $@.*; \
                        touch $@.$$MD5SUM; \