some more build system cleanup
[openwrt/svn-archive/archive.git] / include / subdir.mk
index 79624238b5a027980f40f0a7a58b60852fa8dbd2..3bf1a4bb7918c8d8095325dd1603bdf503e554ad 100644 (file)
@@ -1,29 +1,25 @@
-# debug flags:
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# d: show subdirectory tree
-# t: show added targets
-# l: show legacy targets
-
-ifeq ($(DEBUG),all)
-  build_debug:=dlt
-else
-  build_debug:=$(DEBUG)
-endif
-
-define debug
-$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
-endef
 
-define warn
-$$(if $(call debug,$(1),$(2)),$$(warning $(3)))
-endef
+SUBTARGETS:=clean download prepare compile install update refresh prereq
+
+subtarget-default = $(filter-out ., \
+       $(if $($(1)/builddirs-$(2)),$($(1)/builddirs-$(2)), \
+       $(if $($(1)/builddirs-default),$($(1)/builddirs-default), \
+       $($(1)/builddirs))))
+
+define subtarget
+  $(call warn_eval,$(1),t,T,$(1)/$(2): $($(1)/) $(foreach bd,$(call subtarget-default,$(1),$(2)),$(1)/$(bd)/$(2)))
 
-define warn_eval
-$(call warn,$(1),$(2),$(3)     $(4))
-$(4)
 endef
 
-SUBTARGETS:=clean download prepare compile install update refresh prereq
+
+lastdir=$(word $(words $(subst /, ,$(1))),$(subst /, ,$(1)))
+diralias=$(if $(findstring $(1),$(call lastdir,$(1))),,$(call lastdir,$(1)))
 
 # Parameters: <subdir>
 define subdir
@@ -31,31 +27,34 @@ define subdir
   $(foreach bd,$($(1)/builddirs),
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
-      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
-               @$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+               +$$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE,   ERROR: $(1)/$(bd) failed to build.))
+        $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
 
       # legacy targets
       $(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
+      # aliases
+      $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(target): $(1)/$(bd)/$(target)))
        )
   )
-  $(foreach target,$(SUBTARGETS),
-    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$(if $($(1)/builddirs-$(target)),$($(1)/builddirs-$(target)),$($(1)/builddirs)),$(1)/$(bd)/$(target)))
-  )
+  $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name>
+# Parameters: <subdir> <name> <target> <depends>
 define stampfile
-  $(1)/stamp:=$(STAGING_DIR)/stampfiles/.$(2)_installed
-  $(call rdep,$(1),$$($(1)/stamp))
-
-  $$($(1)/stamp):
-       @$(MAKE) $(1)/install
-       @mkdir -p $$$$(dirname $$($(1)/stamp))
-       @touch $$($(1)/stamp)
-  .PRECIOUS: $$($(1)/stamp) # work around a make bug
-
-  $(1)//clean:=$(1)/stamp/clean
-  $(1)/stamp/clean: FORCE
-       @rm -f $$($(1)/stamp)
+  $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
+  $$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
+       @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
+               $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+       @mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
+       @touch $$($(1)/stamp-$(3))
+
+  $$(if $(call debug,$(1),v),,.SILENT: $$($(1)/stamp-$(3)))
+
+  .PRECIOUS: $$($(1)/stamp-$(3)) # work around a make bug
+
+  $(1)//clean:=$(1)/stamp-$(3)/clean
+  $(1)/stamp-$(3)/clean: FORCE
+       @rm -f $$($(1)/stamp-$(3))
 
 endef