move default templates for the kernel build to kernel-defaults.mk (similar to package...
[openwrt/svn-archive/archive.git] / include / target.mk
index 042e85d326781967f509d6809fe2489993cd7a5c..1718a869c14780853bc61c69f9d66cf4769d87b7 100644 (file)
@@ -5,8 +5,21 @@
 # See /LICENSE for more information.
 #
 
+
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
+  endif
+endef
+
 include $(TMP_DIR)/.target.mk
 
+ifeq ($(IB),1)
+$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
+       $(CP) $< $@
+else
 $(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
-       $(SCRIPT_DIR)/gen_target_mk.pl < $(TMP_DIR)/.targetinfo > $@
+       $(SCRIPT_DIR)/metadata.pl target_mk < $(TMP_DIR)/.targetinfo > $@
+endif