move default templates for the kernel build to kernel-defaults.mk (similar to package...
[openwrt/svn-archive/archive.git] / include / target.mk
index d0f7b9bc2b597c395caa95e1fcc237c90ffb96e2..1718a869c14780853bc61c69f9d66cf4769d87b7 100644 (file)
@@ -5,14 +5,16 @@
 # See /LICENSE for more information.
 #
 
-include $(TMP_DIR)/.target.mk
 
 define AddProfile
-  ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
-    PROFILE=$(1)
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
   endif
 endef
 
+include $(TMP_DIR)/.target.mk
+
 ifeq ($(IB),1)
 $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@