more cosmetic fixes missed from [8250]
[openwrt/svn-archive/archive.git] / include / target.mk
index bd3ceb955b7f00d0f76eb6d6305a2d9be5bd5e68..b0a178e306d409319d0797fa11fe68c7edcc0a80 100644 (file)
@@ -1,17 +1,21 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-include $(TMP_DIR)/.target.mk
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
+  endif
+endef
+
+-include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)
 $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@
-else
-$(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
-       $(SCRIPT_DIR)/metadata.pl target_mk < $(TMP_DIR)/.targetinfo > $@
 endif