[ar7] add back the fixed PHY patches from #3124, until we move this to platform_data
[openwrt/svn-archive/archive.git] / include / target.mk
index 8769c305754f956c2b92803cc1784e41a5584d1a..b30be1032e65fff4ab19d0e5511b76c666e9e0c3 100644 (file)
@@ -162,6 +162,7 @@ ifeq ($(DUMP),1)
   endif
   DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -funit-at-a-time
   DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -funit-at-a-time
+  DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e -funit-at-a-time
   DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time
   DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
   DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -funit-at-a-time
@@ -177,7 +178,7 @@ define BuildTargets/DumpCurrent
        @echo 'Target: $(TARGETID)'; \
         echo 'Target-Board: $(BOARD)'; \
         echo 'Target-Kernel: $(KERNEL)'; \
-        echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),, [$(KERNEL)])$(if $(SUBTARGETS),$(if $(SUBTARGET), [$(KERNEL)]))'; \
+        echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),$(if $(SUBTARGET),))'; \
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \