FPU type should not interfere with the ABI selection.
[openwrt/svn-archive/archive.git] / include / target.mk
index 0f3145df593afe76409d1abd74d287db89b1ac78..eca218e0b370ee9649fae694be90fa57a8a5786c 100644 (file)
@@ -232,8 +232,8 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_mpcore = -march=armv6k -mtune=mpcore
     CPU_CFLAGS_xscale = -march=armv5te -mtune=xscale
     ifneq ($(CONFIG_SOFT_FLOAT),)
-      CPU_CFLAGS_vfp = -mfpu=vfp -mfloat-abi=softfp
-      CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16 -mfloat-abi=softfp
+      CPU_CFLAGS_vfp = -mfpu=vfp
+      CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
     endif
   endif
   ifeq ($(ARCH),powerpc)