[include] target.mk: don't enable coreutils by default, it does not even exist anymor...
[openwrt/svn-archive/archive.git] / include / target.mk
index 1f28fbaa00709959a71627b07076da37ec8259fc..ef5a65665c7bba4f9c9c5734b8887f9b960eda05 100644 (file)
@@ -12,16 +12,11 @@ __target_inc=1
 DEVICE_TYPE?=router
 
 # Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg
+DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg hotplug2
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
 DEFAULT_PACKAGES.bootloader:=
 
-# Additional packages for Linux 2.6
-ifneq ($(KERNEL),2.4)
-  DEFAULT_PACKAGES += udevtrigger hotplug2
-endif
-
 # Add device specific packages
 DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
 
@@ -72,10 +67,10 @@ define Profile
                echo "Target-Profile-Kconfig: yes"; \
        fi; \
        echo "Target-Profile-Config: "; \
-       getvar "$(call shvar,Profile/$(1)/Config)"; \
+       $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Config)"; \
        echo "@@"; \
        echo "Target-Profile-Description:"; \
-       getvar "$(call shvar,Profile/$(1)/Description)"; \
+       $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
        echo;
   ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
@@ -109,13 +104,13 @@ ifneq ($(TARGET_BUILD)$(if $(DUMP),,1),)
   include $(INCLUDE_DIR)/kernel-version.mk
 endif
 
-GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
+GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic
 GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(if $(wildcard $(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
 GENERIC_FILES_DIR := $(foreach dir,$(wildcard $(GENERIC_PLATFORM_DIR)/files $(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)),"$(dir)")
 
 GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
 LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)) $(PLATFORM_DIR)/config-$(KERNEL_PATCHVER))
-LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
+LINUX_SUBCONFIG?=$(if $(SHARED_LINUX_CONFIG),,$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default)))
 ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
   LINUX_SUBCONFIG:=
 endif
@@ -148,7 +143,9 @@ ifeq ($(DUMP),1)
       FEATURES += pcie
     endif
     ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
-      FEATURES += usb
+      ifneq ($(CONFIG_USB_ARCH_HAS_HCD)$(CONFIG_USB_EHCI_HCD),)
+        FEATURES += usb
+      endif
     endif
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
       FEATURES += pcmcia
@@ -162,10 +159,12 @@ ifeq ($(DUMP),1)
   endif
   DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -funit-at-a-time
   DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -funit-at-a-time
+  DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e -funit-at-a-time
   DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time
   DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
   DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -funit-at-a-time
   DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
+  DEFAULT_CFLAGS_sparc=-Os -pipe -mcpu=ultrasparc -funit-at-a-time
   DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time
   DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
   DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe -funit-at-a-time)
@@ -177,9 +176,10 @@ define BuildTargets/DumpCurrent
        @echo 'Target: $(TARGETID)'; \
         echo 'Target-Board: $(BOARD)'; \
         echo 'Target-Kernel: $(KERNEL)'; \
-        echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),, [$(KERNEL)])$(if $(SUBTARGETS),$(if $(SUBTARGET), [$(KERNEL)]))'; \
+        echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),$(if $(SUBTARGET),))'; \
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
+        echo 'Target-Arch-Packages: $(if $(ARCH_PACKAGES),$(ARCH_PACKAGES),$(BOARD))'; \
         echo 'Target-Features: $(FEATURES)'; \
         echo 'Target-Depends: $(DEPENDS)'; \
         echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
@@ -187,7 +187,7 @@ define BuildTargets/DumpCurrent
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
         echo 'Target-Description:'; \
-        getvar $(call shvar,Target/Description); \
+        $(SH_FUNC) getvar $(call shvar,Target/Description); \
         echo '@@'; \
         echo 'Default-Packages: $(DEFAULT_PACKAGES)'; \
         $(DUMPINFO)