enable luci-admin-mini by default as suggested by cyrus
[openwrt/svn-archive/archive.git] / include / target.mk
index c8eb76c254c03089e59347a0aa4e7f849caecc5f..f3826b186548b005c75dc03566c4fbb8d93c050a 100644 (file)
@@ -1,19 +1,34 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-ifneq ($(DUMP),)
-  all: dumpinfo
-endif
-
 ifneq ($(__target_inc),1)
 __target_inc=1
 
-TARGET_BUILD?=0
+# default device type
+DEVICE_TYPE?=router
+
+# Default packages - the really basic set
+DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd uci opkg
+# For router targets
+DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper bridge firewall
+# LuCI
+DEFAULT_PACKAGES.router+=luci-admin-full luci-admin-mini luci-i18n-english luci-app-firewall luci-sgi-cgi
+
+# Additional packages for Linux 2.6
+ifneq ($(KERNEL),2.4)
+  DEFAULT_PACKAGES += udevtrigger hotplug2
+endif
 
+# Add device specific packages
+DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
+
+ifneq ($(DUMP),)
+  all: dumpinfo
+endif
 
 target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
 ifeq ($(DUMP),)
@@ -26,15 +41,6 @@ endif
 TARGETID:=$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET))
 PLATFORM_SUBDIR:=$(PLATFORM_DIR)$(if $(SUBTARGET),/$(SUBTARGET))
 
-define Target
-  KERNEL_TARGETS+=$(1)
-  ifeq ($(DUMP),1)
-    ifeq ($(SUBTARGET),)
-      BuildTarget=$$(BuildTargets/DumpAll)
-    endif
-  endif
-endef
-
 ifneq ($(TARGET_BUILD),1)
   include $(PLATFORM_DIR)/Makefile
   ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
@@ -51,6 +57,7 @@ define Profile/Default
   PACKAGES:=
 endef
 
+ifndef Profile
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
@@ -74,10 +81,25 @@ define Profile
     PROFILE=$(1)
   endif
 endef
+endif
 
--include $(PLATFORM_DIR)/profiles/*.mk
 ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
-  -include $(PLATFORM_SUBDIR)/profiles/*.mk
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
+    -include $(PLATFORM_SUBDIR)/profiles/*.mk
+  endef
+else
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
+  endef
+endif
+
+ifeq ($(TARGET_BUILD),1)
+  $(eval $(call IncludeProfiles))
+else
+  ifeq ($(DUMP),)
+    $(eval $(call IncludeProfiles))
+  endif
 endif
 
 $(eval $(call shexport,Target/Description))
@@ -86,9 +108,10 @@ include $(INCLUDE_DIR)/kernel-version.mk
 
 GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
 GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+GENERIC_FILES_DIR := $(foreach dir,$(wildcard $(GENERIC_PLATFORM_DIR)/files $(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)),"$(dir)")
 
 GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
-LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))
+LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)) $(PLATFORM_DIR)/config-$(KERNEL_PATCHVER))
 LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
 ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
   LINUX_SUBCONFIG:=
@@ -106,36 +129,38 @@ ifeq ($(DUMP),1)
     .SILENT: $(TMP_CONFIG)
     .PRECIOUS: $(TMP_CONFIG)
 
+    ifneq ($(CONFIG_GENERIC_GPIO),)
+      FEATURES += gpio
+    endif
     ifneq ($(CONFIG_PCI),)
       FEATURES += pci
     endif
-    ifneq ($(CONFIG_USB),)
+    ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
       FEATURES += usb
     endif
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
       FEATURES += pcmcia
     endif
+    ifneq ($(CONFIG_VGA_CONSOLE)$(CONFIG_FB),)
+      FEATURES += display
+    endif
 
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
   endif
 endif
 
-define BuildTargets/DumpAll
-  dumpinfo:
-       @$(foreach SUBTARGET,$(KERNEL_TARGETS),$(SUBMAKE) -s DUMP=1 SUBTARGET=$(SUBTARGET); )
-endef
-
 define BuildTargets/DumpCurrent
-
+  .PHONY: dumpinfo
   dumpinfo:
        @echo 'Target: $(TARGETID)'; \
         echo 'Target-Board: $(BOARD)'; \
         echo 'Target-Kernel: $(KERNEL)'; \
-        echo 'Target-Name: $(BOARDNAME) [$(KERNEL)]'; \
+        echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGET),, [$(KERNEL)])'; \
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \
+        echo 'Target-Depends: $(DEPENDS)'; \
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
@@ -144,6 +169,7 @@ define BuildTargets/DumpCurrent
         echo '@@'; \
         echo 'Default-Packages: $(DEFAULT_PACKAGES)'; \
         $(DUMPINFO)
+       $(if $(SUBTARGET),,@$(foreach SUBTARGET,$(SUBTARGETS),$(SUBMAKE) -s DUMP=1 SUBTARGET=$(SUBTARGET); ))
 endef
 
 include $(INCLUDE_DIR)/kernel.mk