Properly extract KERNEL_PATCHVER for linux 3.0
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index fa0bc25878bb48c09d6f6bd48301287e577b379e..19b25d339297d85193c35305264fdac4493db361 100644 (file)
@@ -1,13 +1,12 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
-SHELL:=/usr/bin/env bash
+RELEASE:=Attitude Adjustment
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
 include $(TOPDIR)/include/verbose.mk
@@ -42,6 +41,8 @@ endif
 SCAN_COOKIE?=$(shell echo $$$$)
 export SCAN_COOKIE
 
+SUBMAKE:=umask 022; $(SUBMAKE)
+
 prepare-mk: FORCE ;
 
 prepare-tmpinfo: FORCE
@@ -103,6 +104,9 @@ kernel_oldconfig: prepare_kernel_conf
 kernel_menuconfig: prepare_kernel_conf
        $(_SINGLE)$(NO_TRACE_MAKE) -C target/linux menuconfig
 
+kernel_nconfig: prepare_kernel_conf
+       $(_SINGLE)$(NO_TRACE_MAKE) -C target/linux nconfig
+
 tmp/.prereq-build: include/prereq-build.mk
        mkdir -p tmp
        rm -f tmp/.host.mk
@@ -112,6 +116,9 @@ tmp/.prereq-build: include/prereq-build.mk
        }
        touch $@
 
+printdb: FORCE
+       @$(_SINGLE)$(NO_TRACE_MAKE) -p $@ V=99 DUMP_TARGET_DB=1 2>&1
+
 download: .config FORCE
        @+$(SUBMAKE) tools/download
        @+$(SUBMAKE) toolchain/download
@@ -127,6 +134,13 @@ prereq:: prepare-tmpinfo .config
 
 %::
        @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+       @( \
+               cp .config tmp/.config; \
+               ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
+               if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
+                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+               fi \
+       )
        @+$(SUBMAKE) -r $@
 
 help: