madwifi: napi polling fix
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index e13d66781aaa655f700f434b187fe2a56584aabd..3d7593bf893ec16f067a86bff96761ee3561573f 100644 (file)
@@ -44,8 +44,8 @@ prepare-tmpinfo: FORCE
        ./scripts/metadata.pl package_mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
        touch $(TOPDIR)/tmp/.build
 
-.config: ./scripts/config/conf prepare-tmpinfo
-       @+if [ -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
+.config: ./scripts/config/conf prepare-tmpinfo $(if $(CONFIG_HAVE_DOT_CONFIG),,FORCE)
+       @+if [ \! -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
        fi
@@ -113,14 +113,14 @@ help:
        cat README
 
 docs docs/compile: FORCE
-       @$(_SINGLE)$(SUBMAKE) -j1 -C docs compile
+       @$(SUBMAKE) -j1 -C docs compile
 
 docs/clean: FORCE
-       @$(_SINGLE)$(SUBMAKE) -j1 -C docs clean
+       @$(SUBMAKE) -j1 -C docs clean
 
 distclean:
        rm -rf tmp build_dir staging_dir dl .config* feeds package/feeds package/openwrt-packages bin
-       @$(_SINGLE)$(SUBMAKE) -j1 -C scripts/config clean
+       @$(SUBMAKE) -j1 -C scripts/config clean
 
 ifeq ($(findstring v,$(DEBUG)),)
   .SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package prepare-tmpinfo