netifd: update to latest version, fixes log buffer handling issues, dns issues and...
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index e9384aebca654b0d885c1b31ef9681c753c2437d..4c9b85c21185404c0f46e360ad1d54506b1fab46 100644 (file)
@@ -31,6 +31,8 @@ unexport P4PORT P4USER P4CONFIG P4CLIENT
 # prevent user defaults for quilt from interfering
 unexport QUILT_PATCHES QUILT_PATCH_OPTS
 
+unexport C_INCLUDE_PATH
+
 # make sure that a predefined CFLAGS variable does not disturb packages
 export CFLAGS=
 
@@ -91,9 +93,9 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
 
 prepare_kernel_conf: .config FORCE
 
-ifeq ($(wildcard staging_dir/host/bin/sed),)
+ifeq ($(wildcard staging_dir/host/bin/quilt),)
   prepare_kernel_conf:
-       @+$(SUBMAKE) -r tools/sed/install
+       @+$(SUBMAKE) -r tools/quilt/install
 else
   prepare_kernel_conf: ;
 endif
@@ -134,6 +136,13 @@ prereq:: prepare-tmpinfo .config
 
 %::
        @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+       @( \
+               cp .config tmp/.config; \
+               ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
+               if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
+                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+               fi \
+       )
        @+$(SUBMAKE) -r $@
 
 help: