kernel: update linux 3.2 to 3.2.15
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index cb50dfa3d72f3f03ef50291b740fceafd294782b..9a60139329cdc18a5dca6c8682b8609fff956a54 100644 (file)
@@ -1,12 +1,12 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
+RELEASE:=Attitude Adjustment
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
 include $(TOPDIR)/include/verbose.mk
@@ -31,6 +31,11 @@ unexport P4PORT P4USER P4CONFIG P4CLIENT
 # prevent user defaults for quilt from interfering
 unexport QUILT_PATCHES QUILT_PATCH_OPTS
 
+unexport C_INCLUDE_PATH
+
+# prevent distro default LPATH from interfering
+unexport LPATH
+
 # make sure that a predefined CFLAGS variable does not disturb packages
 export CFLAGS=
 
@@ -91,9 +96,9 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
 
 prepare_kernel_conf: .config FORCE
 
-ifeq ($(wildcard staging_dir/host/bin/sed),)
+ifeq ($(wildcard staging_dir/host/bin/quilt),)
   prepare_kernel_conf:
-       @+$(SUBMAKE) -r tools/sed/install
+       @+$(SUBMAKE) -r tools/quilt/install
 else
   prepare_kernel_conf: ;
 endif
@@ -134,6 +139,13 @@ prereq:: prepare-tmpinfo .config
 
 %::
        @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+       @( \
+               cp .config tmp/.config; \
+               ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
+               if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
+                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+               fi \
+       )
        @+$(SUBMAKE) -r $@
 
 help: