ar71xx: fix AR934X_WMAC_SIZE
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index 53c5f4772daf8cad8b396a0cdfc9f5ff689f0114..b215e41afdb90a0d8d54eb60f621942b081259fc 100644 (file)
@@ -1,13 +1,12 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
-export SHELL:=/usr/bin/env bash
+RELEASE:=Attitude Adjustment
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
 include $(TOPDIR)/include/verbose.mk
@@ -42,6 +41,8 @@ endif
 SCAN_COOKIE?=$(shell echo $$$$)
 export SCAN_COOKIE
 
+SUBMAKE:=umask 022; $(SUBMAKE)
+
 prepare-mk: FORCE ;
 
 prepare-tmpinfo: FORCE
@@ -115,6 +116,9 @@ tmp/.prereq-build: include/prereq-build.mk
        }
        touch $@
 
+printdb: FORCE
+       @$(_SINGLE)$(NO_TRACE_MAKE) -p $@ V=99 DUMP_TARGET_DB=1 2>&1
+
 download: .config FORCE
        @+$(SUBMAKE) tools/download
        @+$(SUBMAKE) toolchain/download
@@ -129,6 +133,13 @@ prereq:: prepare-tmpinfo .config
        @+$(NO_TRACE_MAKE) -r -s $@
 
 %::
+       @( \
+               cp .config tmp/.config; \
+               ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
+               if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
+                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+               fi \
+       )
        @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
        @+$(SUBMAKE) -r $@