[adm5120] fix initcall level in i2c-gpio-custom driver if not built as a module
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index a9ca3a2806ff9955219d3797794547231211c485..c92686019dc691694f28c76eda004b60d03a7e4d 100644 (file)
@@ -16,7 +16,7 @@ include $(TOPDIR)/include/verbose.mk
 ifneq ($(VERSION),)
   OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  REV:=$(if $(wildcard .svn/entries),$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' ))
   ifneq ($(REV),)
     OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
   endif
@@ -52,6 +52,8 @@ prepare-tmpinfo: FORCE
 scripts/config/mconf:
        @+$(MAKE) -C scripts/config all
 
+$(eval $(call rdep,scripts/config,scripts/config/mconf))
+
 scripts/config/conf:
        @+$(MAKE) -C scripts/config conf
 
@@ -120,7 +122,7 @@ symlinkclean:
        rm -rf tmp
 
 distclean:
-       rm -rf tmp build_dir staging_dir dl .config*
+       rm -rf tmp build_dir staging_dir dl .config* feeds
 
 ifeq ($(findstring v,$(DEBUG)),)
   .SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package prepare-tmpinfo