[include] autotools.mk: fix autoreconf in subdirectories, thanks field_it for spottin...
[openwrt/svn-archive/archive.git] / include / toplevel.mk
index cb50dfa3d72f3f03ef50291b740fceafd294782b..d2c8e5eb0c20a746a72c9310291b51413807e20d 100644 (file)
@@ -1,12 +1,12 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
+RELEASE:=Attitude Adjustment
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
 include $(TOPDIR)/include/verbose.mk
@@ -91,9 +91,9 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
 
 prepare_kernel_conf: .config FORCE
 
-ifeq ($(wildcard staging_dir/host/bin/sed),)
+ifeq ($(wildcard staging_dir/host/bin/quilt),)
   prepare_kernel_conf:
-       @+$(SUBMAKE) -r tools/sed/install
+       @+$(SUBMAKE) -r tools/quilt/install
 else
   prepare_kernel_conf: ;
 endif
@@ -134,6 +134,13 @@ prereq:: prepare-tmpinfo .config
 
 %::
        @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+       @( \
+               cp .config tmp/.config; \
+               ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
+               if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
+                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+               fi \
+       )
        @+$(SUBMAKE) -r $@
 
 help: