brcm63xx: migrate platform to common led helper functions
[openwrt/svn-archive/archive.git] / include / uclibc++.mk
index 817484377fcee9c0f55f5238e57a4e62bc791848..89298e3f30bc645f6a8fb6e7903ed0620185f1a9 100644 (file)
@@ -5,8 +5,12 @@ ifndef DUMP
 endif
 
 PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
-CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
+CXX_DEPENDS = @INSTALL_LIBSTDCPP +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
 
 ifneq ($(CONFIG_USE_UCLIBCXX),)
-  TARGET_CXX="g++-uc"
+ ifneq ($(CONFIG_CCACHE),)
+  TARGET_CXX_NOCACHE=g++-uc
+ else
+  TARGET_CXX=g++-uc
+ endif
 endif