add support for marking specific kernel module packages as potentially being required...
[openwrt/svn-archive/archive.git] / include / unpack.mk
index 10e6c25bf5418b5a7fcebc62b036cd05815c827b..2cd17817e6929d216cf31acb1c8514848eb4ecfd 100644 (file)
@@ -1,4 +1,9 @@
-ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))
+# 
+# Copyright (C) 2006-2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 # unpacking files with +s may break on some platforms. this typically emits error code 2
 ifneq ($(HOST_OS),Linux)
@@ -6,13 +11,14 @@ ifneq ($(HOST_OS),Linux)
 else
   HOST_TAR:=$(TAR)
 endif
-TAR_CMD:=$(HOST_TAR) -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS)
-UNZIP_CMD:=unzip -d $(PKG_BUILD_DIR)/.. $(DL_DIR)/$(PKG_SOURCE)
+TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
+UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
 
 ifeq ($(PKG_SOURCE),)
   PKG_UNPACK ?= true
-endif
-ifeq ($(strip $(PKG_UNPACK)),)
+else
+
+ifeq ($(strip $(UNPACK_CMD)),)
   ifeq ($(strip $(PKG_CAT)),)
     # try to autodetect file type
     EXT:=$(call ext,$(PKG_SOURCE))
@@ -20,41 +26,52 @@ ifeq ($(strip $(PKG_UNPACK)),)
 
     ifeq ($(filter gz tgz,$(EXT)),$(EXT))
       EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
-      UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) |
-    endif      
+      DECOMPRESS_CMD:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) |
+    endif
     ifeq ($(filter bzip2 bz2 bz tbz2 tbz,$(EXT)),$(EXT))
       EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
-      UNPACK:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
+      DECOMPRESS_CMD:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
     endif
     ifeq ($(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
-      $(error FOO: $(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
       EXT:=tar
     endif
-    UNPACK ?= cat $(DL_DIR)/$(PKG_SOURCE) |
+    DECOMPRESS_CMD ?= cat $(DL_DIR)/$(PKG_SOURCE) |
     ifeq ($(EXT),tar)
-      PKG_UNPACK:=$(UNPACK) $(TAR_CMD)
+      UNPACK_CMD=$(DECOMPRESS_CMD) $(TAR_CMD)
     endif
     ifeq ($(EXT),cpio)
-      PKG_UNPACK:=$(UNPACK) (cd $(PKG_BUILD_DIR)/..; cpio -i -d)
+      UNPACK_CMD=$(DECOMPRESS_CMD) (cd $(1)/..; cpio -i -d)
     endif
     ifeq ($(EXT),zip)
-      PKG_UNPACK:=$(UNZIP_CMD)
+      UNPACK_CMD=$(UNZIP_CMD)
     endif
   endif
+
   # compatibility code for packages that set PKG_CAT
-  ifeq ($(strip $(PKG_CAT)$(PKG_UNPACK)),)
+  ifeq ($(strip $(UNPACK_CMD)),)
     # use existing PKG_CAT
-    PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
+    UNPACK_CMD=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
     ifeq ($(PKG_CAT),unzip)
-      PKG_UNPACK:=$(UNZIP_CMD)
+      UNPACK_CMD=$(UNZIP_CMD)
     endif
-    # replace zcat with $(ZCAT), because some system have it as gzcat
+    # replace zcat with $(ZCAT), because some system don't support it properly
     ifeq ($(PKG_CAT),zcat)
-      PKG_UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
+      UNPACK_CMD=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
     endif
   endif
   ifneq ($(strip $(CRLF_WORKAROUND)),)
-    PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+    CRLF_CMD := && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+  else
+    CRLF_CMD :=
   endif
 endif
+
+ifdef PKG_BUILD_DIR
+  PKG_UNPACK ?= $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
+endif
+ifdef HOST_BUILD_DIR
+  HOST_UNPACK ?= $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
+endif
+
+endif # PKG_SOURCE
+