Fix typo in last commit
[openwrt/svn-archive/archive.git] / include / verbose.mk
index 4abdf8d661fa6f137111992348999d2e6e0a3d2f..36e59904ecff5fee634ad82e36104d80f61d6162 100644 (file)
@@ -21,12 +21,12 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:="\\033[33m" # yellow
-  _N:="\\033[m" #normal
+  _Y:=\\033[33m
+  _N:=\\033[m
 endif
 
 define MESSAGE
-       /bin/echo -e "$(_Y)$(1)$(_N)" >&3
+       printf "$(_Y)%s$(_N)\n" "$(1)" >&3
 endef
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -37,11 +37,11 @@ ifneq ($(KBUILD_VERBOSE),99)
       _DIR:=
     endif
     _NULL:=$(if $(MAKECMDGOALS),$(shell \
-               $(call MESSAGE, "make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)"); \
+               $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
     ))
   else
     ifeq ($(KBUILD_VERBOSE),0)
-      MAKE:=&>/dev/null $(MAKE)
+      MAKE:=>/dev/null 2>&1 $(MAKE)
     endif
     export QUIET:=1
     MAKE:=cmd() { $(MAKE) -s $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd