use printf instead of echo
[openwrt/svn-archive/archive.git] / include / verbose.mk
index 6b2d6d044ba2722e1d83eefdeb89105f818ca425..36e59904ecff5fee634ad82e36104d80f61d6162 100644 (file)
@@ -8,7 +8,9 @@
 
 ifeq ($(NO_TRACE_MAKE),)
 NO_TRACE_MAKE := $(MAKE) V=99
+SUBMAKE := $(MAKE)
 export NO_TRACE_MAKE
+export SUBMAKE
 endif
 
 ifndef KBUILD_VERBOSE
@@ -19,28 +21,30 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:="\\033[33m" # yellow
-  _N:="\\033[m" #normal
+  _Y:=\\033[33m
+  _N:=\\033[m
 endif
 
 define MESSAGE
-       echo -e "$(_Y)$(1)$(_N)" >&3
+       printf "$(_Y)%s$(_N)\n" "$(1)" >&3
 endef
 
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
-    $(MAKECMDGOALS): trace
-    trace: FORCE
-       @[ -f "$(MAKECMDGOALS)" ] || { \
-               [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               $(call MESSAGE, "make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)"); \
-       }
+    ifneq ($(CURDIR),$(TOPDIR))
+      _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
+    else
+      _DIR:=
+    endif
+    _NULL:=$(if $(MAKECMDGOALS),$(shell \
+               $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
+    ))
   else
-    export QUIET:=1
     ifeq ($(KBUILD_VERBOSE),0)
-      MAKE:=&>/dev/null $(MAKE)
+      MAKE:=>/dev/null 2>&1 $(MAKE)
     endif
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
+    export QUIET:=1
+    MAKE:=cmd() { $(MAKE) -s $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)