add 'mtd refresh' command
[openwrt/svn-archive/archive.git] / include / verbose.mk
index f18e9a2c7105257a7993f284b2220ea548e4280d..4abdf8d661fa6f137111992348999d2e6e0a3d2f 100644 (file)
@@ -26,7 +26,7 @@ ifeq ($(IS_TTY),1)
 endif
 
 define MESSAGE
-       echo -e "$(_Y)$(1)$(_N)" >&3
+       /bin/echo -e "$(_Y)$(1)$(_N)" >&3
 endef
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -44,7 +44,7 @@ ifneq ($(KBUILD_VERBOSE),99)
       MAKE:=&>/dev/null $(MAKE)
     endif
     export QUIET:=1
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
+    MAKE:=cmd() { $(MAKE) -s $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)