minor tweaks to the verbose system
[openwrt/svn-archive/archive.git] / include / verbose.mk
index b4242f212acc512c4d66533932bf86838f374eab..6b2d6d044ba2722e1d83eefdeb89105f818ca425 100644 (file)
@@ -19,17 +19,21 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:="\\33[33m"# yellow
-  _N:="\\33[m"#        normal
+  _Y:="\\033[33m" # yellow
+  _N:="\\033[m" #normal
 endif
 
+define MESSAGE
+       echo -e "$(_Y)$(1)$(_N)" >&3
+endef
+
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
     trace: FORCE
        @[ -f "$(MAKECMDGOALS)" ] || { \
                [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
+               $(call MESSAGE, "make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)"); \
        }
   else
     export QUIET:=1