disable stdin unless make V=99; fixes bug where compilation can stall waiting for...
[openwrt/svn-archive/archive.git] / include / verbose.mk
index f795e28045b0c60084a26b83692fe7707ecfaf73..857be24a32e44c9e44c3c759dce7ca881a7eaca2 100644 (file)
@@ -44,7 +44,7 @@ ifneq ($(KBUILD_VERBOSE),99)
       SILENT:=
     endif
     export QUIET:=1
-    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)