Modified partition table to support jffs2
[openwrt/svn-archive/archive.git] / include / verbose.mk
index 34568a31f821f3c8c3b470240ca82971cfcc4511..99747ed3fd4f46ad6ef347e0260a2f798c4ae374 100644 (file)
@@ -18,9 +18,9 @@ ifeq ("$(origin V)", "command line")
   KBUILD_VERBOSE:=$(V)
 endif
 
-ifneq ($(shell tty -s <&3 || echo x),x)
-  _Y:="\\33[33m"# yellow
-  _N:="\\33[m"#        normal
+ifeq ($(IS_TTY),1)
+  _Y:="\\033[33m" # yellow
+  _N:="\\033[m" #normal
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)