base-files: Update /etc/init.d/fstab with new location of swapon and swapoff (they...
[openwrt/svn-archive/archive.git] / include / verbose.mk
index 36e59904ecff5fee634ad82e36104d80f61d6162..fed83d6fb6f69081081c40daf0f1d8fb555ed6e6 100644 (file)
@@ -25,11 +25,11 @@ ifeq ($(IS_TTY),1)
   _N:=\\033[m
 endif
 
-define MESSAGE
+ifneq ($(KBUILD_VERBOSE),99)
+  define MESSAGE
        printf "$(_Y)%s$(_N)\n" "$(1)" >&3
-endef
+  endef
 
-ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     ifneq ($(CURDIR),$(TOPDIR))
       _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -48,4 +48,8 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+  define MESSAGE
+    printf "%s\n" "$(1)"
+  endef
 endif