cyassl: update to wolfssl 3.6.0
[openwrt/svn-archive/archive.git] / include / version.mk
index c4747f236f9b2a04f0ef825a135cb805271b78c6..69141ff696a1b53eb8ce5839ba5e6296ec1bb65c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%S/packages)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
@@ -53,11 +53,12 @@ $(lastword $(subst :, ,$(1)))
 endef
 
 VERSION_TAINT_SPECS := \
-       -ALL:no-all \
+       -ALL_KMODS:no-all \
        -IPV6:no-ipv6 \
-       +USE_EGLIBC:eglibc \
+       +USE_GLIBC:glibc \
        +USE_MKLIBS:mklibs \
        +BUSYBOX_CUSTOM:busybox \
+       +OVERRIDE_PKGS:override \
 
 VERSION_TAINTS := $(strip $(foreach taint,$(VERSION_TAINT_SPECS), \
        $(if $(findstring +,$(taint)), \