Update aiccu to 20070115 (#1211)
[openwrt/svn-archive/archive.git] / ipv6 / aiccu / Makefile
index 933bf738cc52619b01338bc1d03f5cc9bb8f5752..13e22ad550764347e9b808bfed0cf6443d00d350 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
-PKG_VERSION:=2005.01.31
+PKG_VERSION:=20070115
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
-PKG_MD5SUM:=7c3da5feab3d59fb5a99a45203e0ca56
+PKG_MD5SUM:=0df76e92eb34f4ce8aa3cfcf6896f271
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -23,26 +24,30 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
+  DEPENDS:=+libpthread
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
-  URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
+  URL:=http://www.sixxs.net/tools/aiccu/
 endef
 
 define Build/Configure
-       $(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
+       $(SED) "s,strip,/bin/true," $(PKG_BUILD_DIR)/unix-console/Makefile
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" LDFLAGS="-lpthread" DEBUG=0
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DAICCU_CONSOLE -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpthread" \
+               DEBUG=0
 endef
 
 define Package/aiccu/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m 755 $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
        install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m 755 ./files/aiccu.init $(1)/etc/init.d/aiccu
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
 endef
 
 $(eval $(call BuildPackage,aiccu))