[packages] aiccu: add dependency on kmod-tun (closes: #4620)
[openwrt/svn-archive/archive.git] / ipv6 / aiccu / Makefile
index 862fd3a83f97f4bf5e911323505bccac8af227ad..b2845ecba7fdeb60666dbb6bac91a8522cee119c 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
@@ -23,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+libpthread +ntpclient +ip +kmod-sit
+  DEPENDS:=+libpthread +ntpclient +ip +kmod-sit +kmod-tun
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
   URL:=http://www.sixxs.net/tools/aiccu/
 endef
@@ -41,14 +40,14 @@ define Build/Compile
 endef
 
 define Package/aiccu/conffiles
-/etc/aiccu.conf
+/etc/config/aiccu
 endef
 
 define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/config/aiccu
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface