fix aiccu compile
[openwrt/svn-archive/archive.git] / ipv6 / aiccu / Makefile
index 0b933e2c0bc4d83aec67e8b9c328a5621308c3fb..b2ac2f9e38ddd4ea12542631174ac197b72873ce 100644 (file)
@@ -40,11 +40,15 @@ define Build/Compile
                DEBUG=0
 endef
 
+define Package/aiccu/conffiles
+/etc/config/aiccu
+endef
+
 define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/config/aiccu
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface