fix aiccu compile
[openwrt/svn-archive/archive.git] / ipv6 / aiccu / Makefile
index 8dc5245c79b646f8bf139c23c9107d94aba9e91e..b2ac2f9e38ddd4ea12542631174ac197b72873ce 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+libpthread +ntpclient
+  DEPENDS:=+libpthread +ntpclient +ip +kmod-sit
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
   URL:=http://www.sixxs.net/tools/aiccu/
 endef
@@ -34,19 +34,25 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DAICCU_CONSOLE -DHAS_IFHEAD -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpthread" \
+               CC="$(TARGET_CC)" OS_NAME="Linux" OS_VERSION="$(LINUX_VERSION)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               EXTRA_LDFLAGS="$(TARGET_LDFLAGS) -pthread" \
                DEBUG=0
 endef
 
+define Package/aiccu/conffiles
+/etc/config/aiccu
+endef
+
 define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/config/aiccu
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/aiccu.hotplug $(1)/etc/hotplug.d/iface/30-aiccu
 endef
 
 $(eval $(call BuildPackage,aiccu))