Upgrade babel to 0.14
[openwrt/svn-archive/archive.git] / ipv6 / aiccu / Makefile
index 1ec7de4ad2b112055f7a3780aa81f7b7552e88a3..d7afecb7059ef029b8b1b46e49e821884d6deddf 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
-PKG_VERSION:=2006.07.25
+PKG_VERSION:=20070115
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
-PKG_MD5SUM:=0df76e92eb34f4ce8aa3cfcf6896f271
-PKG_CAT:=zcat
+PKG_MD5SUM:=c9bcc83644ed788e22a7c3f3d4021350
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -24,27 +23,32 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
+  DEPENDS:=+libpthread +ntpclient +ip +kmod-sit
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
-  URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
+  URL:=http://www.sixxs.net/tools/aiccu/
 endef
 
 define Build/Configure
-       $(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
+       $(SED) "s,strip,/bin/true," $(PKG_BUILD_DIR)/unix-console/Makefile
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-lpthread" DEBUG=0
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DAICCU_CONSOLE -DHAS_IFHEAD -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpthread" \
+               DEBUG=0
 endef
 
 define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(1)/etc/
+       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/aiccu.hotplug $(1)/etc/hotplug.d/iface/30-aiccu
 endef
 
 $(eval $(call BuildPackage,aiccu))