[Packages] admin/htop: Update to 0.7 (#3415)
[openwrt/svn-archive/archive.git] / ipv6 / babel / Makefile
index bc4924748d77243b38741f716ea796f1ffe04e00..26b9b6a3ba683b9ef5f00926bc936f094f06e53d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,42 +9,36 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babel
-PKG_VERSION:=0.4
+PKG_VERSION:=0.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=427bbd044d9e842c8ed203d1b8d5dd6e
+PKG_MD5SUM:=33a4f783ae7b6ed25668473ee9771297
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/babel
   SECTION:=ipv6
   CATEGORY:=IPv6
-  TITLE:=Ad-Hoc network routing daemon
-  URL:=http://www.pps.jussieu.fr/~jch/software/ahcp/
+  TITLE:=A loop-free distance-vector routing protocol
+  URL:=http://www.pps.jussieu.fr/~jch/software/babel/
   DEPENDS:=+kmod-ipv6
 endef
 
 define Package/babel/description
- Babel is a loop-avoiding distance-vector routing protocol roughly based 
- on DSDV and AODV, but with provisions for link cost estimation and 
+ Babel is a loop-avoiding distance-vector routing protocol roughly based
+ on DSDV and AODV, but with provisions for link cost estimation and
  redistribution of routes from other routing protocols.
- While it is optimised for wireless mesh networks, Babel will also work 
- efficiently on wired networks. It will generate between roughly the same 
- and double the amount of routing traffic that RIPng would generate, while 
+ While it is optimised for wireless mesh networks, Babel will also work
+ efficiently on wired networks. It will generate between 1.2 and 2.4 times
+ the amount of routing traffic that RIPng would generate, while
  never counting to infinity.
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all
-endef
+MAKE_FLAGS += \
+       CC="$(TARGET_CC)" \
+       CFLAGS="$(TARGET_CFLAGS)" \
 
 define Package/babel/install
        $(INSTALL_DIR) $(1)/usr/sbin