Upgrade babel to 0.11 (#3286)
[openwrt/svn-archive/archive.git] / ipv6 / babel / Makefile
index 8a4ec94c4a41feae8036bc0893459086b208b5ee..327a0ec3133204307341c0bb96daf15de82757e5 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babel
-PKG_VERSION:=0.5
+PKG_VERSION:=0.11
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=7c88c0b2bc537f3dc89c595b9dba99f1
+PKG_MD5SUM:=390bd17c00f009f6364d70a0fb9777fb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,24 +27,18 @@ define Package/babel
 endef
 
 define Package/babel/description
- Babel is a loop-avoiding distance-vector routing protocol roughly based 
- on DSDV and AODV, but with provisions for link cost estimation and 
+ Babel is a loop-avoiding distance-vector routing protocol roughly based
+ on DSDV and AODV, but with provisions for link cost estimation and
  redistribution of routes from other routing protocols.
- While it is optimised for wireless mesh networks, Babel will also work 
- efficiently on wired networks. It will generate between 1.2 and 2.4 times 
- the amount of routing traffic that RIPng would generate, while 
+ While it is optimised for wireless mesh networks, Babel will also work
+ efficiently on wired networks. It will generate between 1.2 and 2.4 times
+ the amount of routing traffic that RIPng would generate, while
  never counting to infinity.
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all
-endef
+MAKE_FLAGS += \
+       CC="$(TARGET_CC)" \
+       CFLAGS="$(TARGET_CFLAGS)" \
 
 define Package/babel/install
        $(INSTALL_DIR) $(1)/usr/sbin