[packages] babel: update to v0.95
[openwrt/svn-archive/archive.git] / ipv6 / babel / Makefile
index dce8e32b6cc12402d5912f684f63d80ae37fe9a5..9bfa44286d6bc43d5f8c3987ce4a8e2a420663c9 100644 (file)
@@ -1,54 +1,55 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babel
-PKG_VERSION:=0.2
+PKG_VERSION:=0.95
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=6d626b414fac86c11e6f57e52bdedb9b
+PKG_MD5SUM:=942094c35acf850235d60831bb0dca38
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/babel
   SECTION:=ipv6
   CATEGORY:=IPv6
-  TITLE:=Ad-Hoc network routing daemon
-  URL:=http://www.pps.jussieu.fr/~jch/software/ahcp/
+  TITLE:=A loop-free distance-vector routing protocol
+  URL:=http://www.pps.jussieu.fr/~jch/software/babel/
   DEPENDS:=+kmod-ipv6
 endef
 
 define Package/babel/description
- Babel is a loop-avoiding distance-vector routing protocol roughly based 
- on DSDV and AODV, but with provisions for link cost estimation and 
+ Babel is a loop-avoiding distance-vector routing protocol roughly based
+ on DSDV and AODV, but with provisions for link cost estimation and
  redistribution of routes from other routing protocols.
- While it is optimised for wireless mesh networks, Babel will also work 
- efficiently on wired networks. It will generate between roughly the same 
- and double the amount of routing traffic that RIPng would generate, while 
+ While it is optimised for wireless mesh networks, Babel will also work
+ efficiently on wired networks. It will generate between 1.2 and 2.4 times
+ the amount of routing traffic that RIPng would generate, while
  never counting to infinity.
 endef
 
-define Build/Configure
+define Package/babel/conffiles
+/etc/babel.conf
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all
-endef
+MAKE_FLAGS += \
+       CC="$(TARGET_CC)" \
+       CFLAGS="$(TARGET_CFLAGS)" \
 
 define Package/babel/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/babel $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/babel.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/babel.init $(1)/etc/init.d/babel
 endef
 
 $(eval $(call BuildPackage,babel))