[package] change libpopt mirror
[openwrt/svn-archive/archive.git] / ipv6 / dibbler / Makefile
index 00e55a9ab9128070be4e6eb0dae83e3182c033a2..21d5e196b156e02f02dec2200e2388a19db79c72 100644 (file)
@@ -1,55 +1,73 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dibbler
-PKG_VERSION:=0.5.0
+PKG_VERSION:=0.7.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
-PKG_SOURCE_URL:=http://klub.com.pl/dhcpv6/dibbler
-PKG_MD5SUM:=26a0e37512be7641a2deb0dc5b00e582
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=76a814d528274b2dc7ff7623bd6f6b45
 
 include $(INCLUDE_DIR)/package.mk
 
+# add dependency on 2.6 since recent dibbler needs <linux/ip_mp_alg.h>
 define Package/dibbler/Default
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+uclibcxx
+  DEPENDS:=+uclibcxx @LINUX_2_6
   TITLE:=Dibbler, a portable DHCPv6 implementation
   URL:=http://klub.com.pl/dhcpv6/
 endef
 
+define Package/dibbler/Default/description
+       Dibbler is a portable DHCPv6 implementation. It supports stateful (i.e.
+       IPv6 address granting) as well as stateless (i.e. option granting)
+       autoconfiguration for IPv6.
+endef
+
 define Package/dibbler-client
   $(call Package/dibbler/Default)
   TITLE+= (client)
 endef
 
+define Package/dibbler-client/description
+  $(call Package/dibbler/Default/description)
+  This package contains the dibbler client.
+endef
+
 define Package/dibbler-relay
   $(call Package/dibbler/Default)
   TITLE+= (relay)
 endef
 
+define Package/dibbler-relay/description
+  $(call Package/dibbler/Default/description)
+  This package contains the dibbler relay.
+endef
+
 define Package/dibbler-server
   $(call Package/dibbler/Default)
   TITLE+= (server)
 endef
 
+define Package/dibbler-server/description
+  $(call Package/dibbler/Default/description)
+  This package contains the dibbler server.
+endef
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR)/poslib; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="$(EXTRA_CPPFLAGS)" \
-               LDFLAGS="$(EXTRA_LDFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
@@ -73,29 +91,32 @@ define Build/Configure
        );
 endef
 
-CXX_LIBS:= -nodefaultlibs -Wl,-Bdynamic,-luClibc++,-Bstatic,-lstdc++,-Bdynamic,-lm,-lc,-lgcc
+# link stuff missing from uClibc++ but present in stdc++ statically
+CXX_LIBS:= -nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -lm -lgcc
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               PORT_CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS) -fno-builtin -fno-rtti" \
-               PORT_LDFLAGS="$(EXTRA_LDFLAGS)" \
+               PORT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -fno-builtin" \
+               PORT_LDFLAGS="$(TARGET_LDFLAGS)" \
                DEBUGINFO= \
+               CXXLD="$(TARGET_CC)" \
                CLNT_LIBS="$(CXX_LIBS)" \
                SRV_LIBS="$(CXX_LIBS)" \
                server client relay
 endef
 
-define Package/dibbler-client/install  
+define Package/dibbler-client/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-client $(1)/usr/sbin/
 endef
 
-define Package/dibbler-relay/install   
+define Package/dibbler-relay/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-relay $(1)/usr/sbin/
 endef
 
-define Package/dibbler-server/install  
+define Package/dibbler-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-server $(1)/usr/sbin/
 endef